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1. Процесс моделирования c использованием  Ansys 

Workbench/LS Dyna для явных вычислений. 

 

1.1. Структура, описание программы 

Программа LS-DYNA в ANSYS WORKBENCH подключается 

при помощи ACT расширения Workbench ls-dyna. Начиная с 19-й вер-

сии ANSYS данный модуль входит в стандартное обеспечение и не 

требует отдельной загрузки из базы приложений ACT. 

Данное расширение позволяет решать задачи динамики в явной 

постановке с помощью LS-DYNA в среде Ansys Workbench. Настрой-

ка модели LS-DYNA и просмотр полученных результатов решения 

выполняются в графическом интерфейсе аналогичном интерфейсу 

ANSYS Mechanical. 

Преимущества работы в данном интерфейсе: 

- импорт геометрических моделей из большинства современных 

CAD-пакетов; 

- «чистка» и исправление геометрии для построения качествен-

ной сетки;  

- параметризация модели;  

- мощный сеточный редактор с множеством гибких настроек и 

функций;  

- создание сеток в параллельном режиме;  

- выполнение расчетов в параллельном режиме;  

- широкие возможности по обработке результатов 

Решателем ANSYS LS-DYNA поддерживается полный набор 

команд, описанных в руководстве пользователя LS-DYNA версии 

971. Однако в графическом интерфейсе расширения представлен 

ограниченный набор наиболее часто используемых команд, необхо-

димых для большинства расчетов. В основном это расчеты, связанные 

с деформированием твердых тел. Существует возможность по опре-

делению контактов, начальных и граничных условий, нагрузок, кон-

тролю количества точек интегрирования в элементах, настройке ана-
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лиза, а также контролю эффекта hourglass. Кроме того, пользователи 

могут дополнять выходной командный файл собственными ключевы-

ми словами. 

Области применения Ansys Workbench/LS-Dyna: 

- технологические процессы деформирования твердых тел и 

процессы обработки металлов давлением; 

- низкоскоростные удары и разрушения конструкций; 

- баллистика боеприпасов и средств поражения; 

- тесты на падения (дроп-тесты). 

 

По моделям материала программа Ansys Workbench/LS-Dyna 

уже имеет встроенные модели с константами (параметрами) (более 

200 материалов). 

 

1.2. Предпроцессор Ansys Workbench 

 

Ansys Workbench поддерживает объемные, оболочечная, балоч-

ные и пружинные типы элементов. 

Подробно про типы элементов описано в первой части. В дан-

ной части описывается способ определения типов элементов приме-

нительно к программе Ansys Workbench/LS-Dyna 

Для выбора программы Ansys Workbench/LS-Dyna требуется 

включения расширение LS-DYNA (подробная последовательность 

действий приведена в примерах). 

В результате появляется окно Workbench LS-DYNA  
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Engineering Data – определение 

параметров моделей материала; 

Geometry – создание геометрии в 

программе Design Modeler или 

SpaceClaim; 

Model, Setup, Solution – опреде-

ление параметров моделирова-

ния используя программу Ansys 

Mechanical; 

Results – просмотр результатов 

моделирования. 

 

 

 

1.2.1. Типы элементов. 

1.2.1.1.  Объемные элементы 

 

Присвоение свойств для solid геометрии осуществляется коман-

дой 

Project → Model → Geometry → Solid 

 

 

Данное меню позволяет выбрать: 
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Stiffness Behavior – поведение материала (Flexible или Rigid). 

Assignment – выбор модели материала для данной геометрии. 

 

Для определения параметра Hourglass используется следующая 

команда: 

Project → Model → Workbench LS-DYNA → Hourglass control 

 

Hourglass Type – тип контроля параметра Hourglass. 

Hourglass, Quadratic Bulk, Linear Bulk – Коэффициенты Hourglass. 

 

 

1.2.1.2.  Оболочечные элементы 

 

Присвоение свойств для плоскостной геометрии осуществляется 

командой: 

Project → Model → Geometry → Surface Body 
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Данное меню позволяет выбрать: 

Stiffness Behavior – поведение матери-

ала (Flexible или Rigid); 

Thickness – толщину элемента; 

Offset Type – выбор плоскости 

(Middle, Top или Bottom); 

Assignment – выбор модели материала 

для данной геометрии. 

 

Также можно использовать дополнительные элементы управле-

ния формулировкой элемента и контролем Hourglass: 

Project → Model → Workbench LS-DYNA → Section 

 

Formulation – выбор элементной 

формулировки; 

Through Thickness integration – 

количество точек интегрирования 

по толщине. 

 

Project → Model → Workbench LS-DYNA → Hourglass control 

 

Hourglass Type – тип контроля 

параметра Hourglass; 

Hourglass, Quadratic Bulk, Linear 

Bulk – Коэффициенты Hourglass. 
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1.2.1.3.  Балочные элементы 

 

Присвоение свойств для балочной геометрии осуществляется 

командой: 

Project → Model → Geometry → Line Body 

 

Данное меню позволяет выбрать: 

Stiffness Behavior – поведение мате-

риала (Flexible или Stiff beam); 

Thickness – толщину элемента; 

Offset Type – вид балки; 

Assignment – выбор модели материа-

ла для данной геометрии. 

 

Выбор элементных формулировок для балочных элементов 

осуществляется следующей командой: 

Project → Model → Workbench LS-DYNA → Section 

 

Formulation – выбор формули-

ровки балочного элемента (beam, 

truss, cable). 

 

 

Для построения круглых балок также может использоваться ко-

манда: 

 Project → Model → Connection → Beam 
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Radius – радиус балки; 

Behavior – жесткая или деформи-

руемая балка; 

Body – конечные узлы балки. 

 

1.2.1.4.  Дискретные элементы 

К дискретным элементам относятся пружинные элементы и 

демпферы. 

Поведение пружин только линейное и поддерживается предва-

рительное нагружение. 

 

Для построения дискретных элементов используется команда: 

Project → Model → Connection → Spring 

 

Longitudinal Stiffness – жесткость 

пружины; 

Longitudinal Damping – величина 

демпфирования; 

Preload – наличие преднагруже-

ния. 
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1.2.2. Модели материалов. 

Программа ANSYS Workbench LS-DYNA (без включения от-

дельных ключевых слов) поддерживает не все материалы доступные в 

LS-DYNA. 

Для определения моделей материала используется закладка En-

gineering Data окне Workbench LS-DYNA. Для ввода требуемых пара-

метров, которыми будет характеризоваться выбираемая модель, ис-

пользуется закладка Filter Engineering Data (выбрана по умолчанию). 

Параметры представлены в панели Toolbox (слева). 

  

Physical Properties – физические свойства: плот-

ность и параметры демпфирования; 

Linear Elastic – параметры упругости для изо-

тропной, ортотропной и анизотропной модели; 

Hyperelastic Experimental Data – эксперимен-

тальные данные с растяжения образцов; 

Hyperelastic – параметры для моделей резины; 

Plasticity – параметры для пластических моделей 

материала; 

Thermal – параметры для тепловых моделей ма-

териала; 

Equations of State – параметры уравнения состо-

яний; 

Failure – параметры разрушения материала; 

Forming Plasticity – параметры пластичности для 

процессов формования; 

Foams – параметры для моделирования пены; 

Eulerian – параметры для моделирования Ейле-
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ровых свойств. 

 

например, Вакуума 

 

 

После выбора требуемых параметров в окне Properties of Outline 

Row появляются желтые строчки в которых вводятся количественные 

значения. Единицы, в которых необходимо ввести указываются в 

правом столбце. 
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Программа ANSYS Workbench LS-DYNA позволяет использо-

вать уже встроенные значения более чем для 200 материалов, которые 

заложены в базу данных программы. 

Данные значения также находятся в Закладке Engineering Data 

Sources. 

 

Модели для конкретных материалов: алюминий, 

воздух, бериллий, латунь, С4, Кадмий, Хром, Ко-

бальт, Бетон, медь, золото, сталь, никель, резина, 

серебро, титан, TNT, вода, цинк (всего более 200 

материалов) 

 

Примеры моделей материала доступные в ANSYS Workbench 

LS-DYNA приведены в таблице 

Модели ма-

териала 

Обозначение через keyword Номер материала в 

keyword 

Linear Elastic 

- Isotropic MAT_ELASTIC *MAT_001 

- Ortho-

tropic 

MAT_ORTHOTROPIC_ 

ELASTIC 

*MAT_002 

- Aniso-   
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tropic 

Plasticity 

- Bilinear 

isotropic 

MAT_MODIFIED_PIECEWISE_ 

LINEAR_PLASTICITY 

*MAT_123 

- Multy-

linear iso-

tropic 

MAT_PIECEWISE_LINEAR_ 

PLASTICITY 

*MAT_024 

- Bilinear 

kinematic 

MAT_PLASTIC_KINEMATIC *MAT_003 

- Johnson 

Cook 

MAT_JOHNSON_COOK *MAT_015 

Hyper Elastic 

- Mooney-

Rivlin 

MAT_HYPERELASTIC_ 

RUBBER 

*MAT_007_H 

- Polynomi-

nal 

MAT_HYPERELASTIC_ 

RUBBER 

MAT_007_H 

- Yeoh MAT_HYPERELASTIC_ 

RUBBER 

MAT_007_H 

- Ogden MAT_OGDEN_RUBBER MAT_007_O 

- Arruda 

Boyce 

  

Rigid 

Rigid  *MAT_020 

Equatioan of state 

- Linear EOS_LINEAR_POLYNOMIAL  

- Shock Lin-

ear 

EOS_GRUNEISEN  

Failure 

- Plastic 

strain  

 MAT_ADD_EROSION 
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- Principal 

stress 

 MAT_ADD_EROSION 

- Johnson 

cook Tensile 

Failure 

 *MAT_015 

 

1.2.3. Сетка для явных вычислений,  элементы формулировки. 

 

Нанесение сетки осуществляется встроенным в Ansys сеточным 

редактором. Для этих целей в дереве “Проект” имеется пункт Mesh. 

 

 

Настройки можно осуществить в окне снизу Details of Mesh 

 

Physics Preference – настройка 

параметров сетки под тип реша-

теля. В данном случае Expicit; 

Relevance – шкала меняющая 

средний размер элементов сетки 

(от -100 до 100); 

Element Order – выбор порядка 

элемента (линейный или квадра-

тичный со средней точкой); 

Sizing – точные настройки пара-

метров сетки. 
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Для выбора метода нанесения сетки используется меню: Верх-

няя панель → Mesh Control → Method 

 

Geometry – выбор геометрии ко-

торую нужно разбить нужным 

методом; 

Method – метод разбиения (авто-

матический, тетра, hex и др.); 

Element Order – выбор порядка 

элемента для конкретной геомет-

рии (линейный или квадратич-

ный со средней точкой). 

 

Основные виды линейных и квадратичных элементов 

Тип элемен-

та 

Линейные* Квадратичные** 

Прямо-

угольные 

shell  

 

ELFORM:=2 

 

ELFORM:=23 

6-и гранный 

solid 

 

ELFORM:=1 

 

ELFORM:=23 
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4-х гранный 

solid 

 

ELFORM:=10 

 

ELFORM:=16 

 

Замечания: 

1. Определение линейных элементов в программе Ansys Workbench 

ls-dyna: Project → Model → Mesh; Element Order – Linear; 

2. Определение квадратичных элементов в программе Ansys Work-

bench ls-dyna: Project → Model → Mesh; Element Order – Quadratic; 

3. 6-и гранные квадратичные элементы не доступны в Ansys Work-

bench ls-dyna. Эти элементы можно предобразовать из 8-и узловых 

элементов используя программу ls-prepost (Mesh → EleGen → Solid → 

Hex8_to_Hex20). 

 

Для разделения геометрии на требуемое число разбиения ис-

пользуется меню: Верхняя панель → Mesh Control → Sizing 

 

Geometry – выбор геометрии которую 

нужно разбить (объем, поверхность, ли-

ния); 

Type разбиения – размер элемента, коли-

чество элементов и др.; 

Element Size – Величина; 

Behavior – поведение при разбиении 

(жесткое или мягкое). 
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Примеры разбиения для конкретных типов элементов приведе-

ны далее 

2D Trian-

gle  

 

Project → Model → Mesh 

→ Automatic method 

  

2D Quad-

rangle  

 

Project → Model → Mesh 

→ Automatic method 

 
 

Shell Tri-

angle  

 

Project → Model → Mesh 

→ Automatic method 

  

Shell 

Quadrangle  

 

Project → Model → Mesh 

→ Automatic method 

  

Solid Tetra 

 

Project → Model → Mesh 

→ Patch Conforming 

Method 
 

Solid Hex 

 

Project → Model → Mesh 

→ Hex Dominant Method 

 

 

Подробнее про нанесении сеточной геометрии можно найти в 

help по программе ansys workbench ls-dyna 

 

1.2.4. Контактные алгоритмы (типы, настройки контактов). 

 

Программа ANSYS Workbench LS-DYNA поддерживает основ-

ные типы контактов, которых достаточно для описания деформирова-
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ния твердых тел. Подробное выбор, описание приведено далее. Также 

приведено соответствие контактов ключевым словам в LS-DYNA. 

 

№ Путь в меню  

Project → Model 

Путь в меню  

Project →  

Workbench  

LS-DYNA 

Карта контак-

та 

Пояснение 

1 Project →  

Model → Connec-

tions → Body In-

teraction 

 

- CONTACT_ 

AUTOMATIC_ 

SINGLE_ 

SURFACE 

Контакт все со 

всеми (приме-

няется, напри-

мер, при краш-

тестах когда 

контактные по-

верхности зара-

нее не извест-

ны) 

2 Project →  

Model → Work-

bench  

LS-DYNA → 

Contact properties 

 

Type: Program 

Controlled 

 

CONTACT_ 

AUTOMATIC_ 

SINGLE_ 

SURFACE 

3 

 

Type: General 

CONTACT_ 

AUTOMATIC_ 

GENERAL 

Контакт все со 

всеми (аналог 

Single surface) 

4 

 

Type: Eroding 

CONTACT_ 

ERODING_ 

SINGLE_ 

SURFACE 

Применяется 

при разрушаю-

щем контакте. 

Например, при 

контакте заго-

товки с отходом 

при сверлении  
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5 Project →  

Model → Connec-

tions → Contacts 

→ Frictionless* 

 

Behavior – Pro-

gram Controlled (or 

Symmetric) 

- CONTACT_ 

AUTOMATIC_ 

SURFACE _ 

TO _ SUR-

FACE** 

 

Применяется в 

большинстве 

случаев (без па-

раметров тре-

ния) 

6 Project →  

Model → Work-

bench  

LS-DYNA → 

Contact properties 

**** 

 

Type: Program 

Controlled 

CONTACT_ 

AUTOMATIC_ 

SURFACE _ 

TO _ SUR-

FACE 

 

7 

 

Type: Eroding 

CONTACT_ 

AUTOMATIC_ 

SURFACE _ 

TO _ SUR-

FACE 

Применяется в 

процессах с 

разрушением 

материала (без 

параметров 

трения) 

8 

 

Type: Forming 

CONTACT_ 

FORMING _ 

SURFACE _ 

TO _ SUR-

FACE 

Применяется в 

процессах фор-

мования (без 

параметров 

трения) 

9 

 

- CONTACT_ Применяется 
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Behavior – Asym-

metric 

AUTOMATIC_ 

NODES _ TO _ 

SURFACE 

 

когда нужно 

обеспечить кон-

такт с узлами 

подчиненной 

части 

10 Project →  

Model → Work-

bench  

LS-DYNA → 

Contact properties 

 

Type: Eroding 

CONTACT_ 

ERODING _ 

NODES _ TO _ 

SURFACE 

 

Применяется в 

когда нужно 

обеспечить кон-

такт с узлами 

подчиненной 

части при раз-

рушении 

11 Project →  

Model → Work-

bench  

LS-DYNA → 

Contact properties 

 

Type: Forming 

CONTACT_ 

FORMING _ 

ONE_WAY_ 

SURFACE _ 

TO _ SUR-

FACE 

Применяется в 

процессах фор-

мования (без 

параметров 

трения). Ис-

пользуется од-

нопроходный 

поиск контакта 

12 Project →  

Model → Connec-

tions → Contacts 

→ Bonded* 

 CONTACT_ 

TIED_ 

SURFACE _ 

TO _ SUR-

Применяется 

для связи ча-

стей (поверхно-

стей) друг с 
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FACE_ OFF-

SET 

 

другом 

13 

 

Behavior – Asym-

metric 

 CONTACT_ 

TIED_ 

NODES_ TO _ 

SURFACE_ 

OFFSET 

 

14 

 

Breakable – Stress 

Criteria 

 CONTACT_ 

AUTOMATIC 

SURFACE _ 

TO _ SUR-

FACE_ TIE-

BREAK 

 

Применяется 

для связи ча-

стей (поверхно-

стей) друг с 

другом с пара-

метрами разру-

шение контакта 

15 

 

Behavior – Asym-

metric 

Breakable – Stress 

Criteria 

 CONTACT_ 

AUTOMATIC_ 

ONE_WAY_ 

SURFACE _ 

TO _ SUR-

FACE_ TIE-

BREAK 

 

Применяется 

для связи ча-

стей (поверхно-

стей) друг с 

другом с пара-

метрами разру-

шение контакта. 

Однопроходный 

контакт 

16 Project →  

Model → Connec-

tions → Contacts 

→ Frictional 

 CONTACT_ 

AUTOMATIC_ 

SURFACE _ 

TO _ SUR-

Применяется в 

большинстве 

случаев (с па-

раметрами тре-
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FACE *** 

 

ния Frictional , 

Dynamic coeffi-

cient, Decay 

conctant)  

17 Project →  

Model → Work-

bench  

LS-DYNA → 

Contact properties 

**** 

 

Type: Program 

Controlled 

CONTACT_ 

AUTOMATIC_ 

SURFACE _ 

TO _ SUR-

FACE 

 

18 

 

Type: Eroding 

CONTACT_ 

AUTOMATIC_ 

SURFACE _ 

TO _ SUR-

FACE 

Применяется в 

процессах с 

разрушением 

материала (с 

параметрами 

трения) 

19 

 

Type: Forming 

CONTACT_ 

FORMING _ 

SURFACE _ 

TO _ SUR-

FACE 

Применяется в 

процессах фор-

мования (с па-

раметрами тре-

ния) 

20 

 

- CONTACT_ 

AUTOMATIC_ 

NODES _ TO _ 

SURFACE 

 

Применяется в 

когда нужно 

обеспечить кон-

такт с узлами 

подчиненной 
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Behavior – Asym-

metric 

части 

21 Project →  

Model → Work-

bench  

LS-DYNA → 

Contact properties 

 

Type: Eroding 

CONTACT_ 

ERODING _ 

NODES _ TO _ 

SURFACE 

 

Применяется в 

когда нужно 

обеспечить кон-

такт с узлами 

подчиненной 

части при раз-

рушении (с па-

раметрами тре-

ния) 

22 Project →  

Model → Work-

bench  

LS-DYNA → 

Contact properties 

 

Type: Forming 

CONTACT_ 

CONTACT_ 

FORMING _ 

ONE_WAY_ 

SURFACE _ 

TO _ SUR-

FACE 

Применяется в 

процессах фор-

мования (с па-

раметрами тре-

ния). Использу-

ется однопро-

ходный поиск 

контакта 

* - для вывода данного меню нажать правой кнопкой на “Con-

nections” выбрать Insert → Manual Contact Region; 

** - Soft constraint = 2 (Рекомендуется к применению при раз-

личных контактных материалах); 

*** - Soft constraint = 0 (Рекомендуется к применению при схо-

жих контактных материалах); 

**** - Меню позволяет задать: время рождения и смерти кон-

такта, коэффициент демпфирования контакта, параметр Soft 

constraint. 
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Для определении сварной точки используется команда: Project 

→ Model → Connections → Contacts → Weld 

 

Contact и Tanget – указываются 2 

точки между которыми будет со-

здана сварная точка 

Breakable – включение разреше-

ния сварной точки 

 

1.2.5. Начальные условия. 

 

В качестве начальных условий в ANSYS Workbench LS-DYNA 

может быть выбрана: начальная линейная скорость,  начальная угло-

вая скорость, высота падения при дроп-тесте.  

Для этих целей используется команда: 

Project → Model → Workbench LS-DYNA → Initial Condition → Veloc-

ity 

 

Geometry – указать геометрию на 

которую прикладываются 

начальные условия; 

Input Type – тип начальных усло-

вий (линейная скорость, угловая 

скорость, высота падения); 

Define By – определение с помо-

щью компонент ли вектора; 

X, Y, Z Component – значения 

скорости. 

 

1.2.6. Граничные условия. 

 

В качестве граничных условий можно ввести ограничения, 

нагрузки и ускорения. 
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Граничные условия можно определить нажав правой кнопкой на 

меню Workbench LS-DYNA → Insert 

 

Для полной фиксации модели используется команда 

Project → Model → Workbench LS-DYNA → Fixed support 

 

Geometry – указать геометрию на 

которую прикладываются полные 

ограничения 

 

Для задания перемещения на требуемую геометрию применяет-

ся команда: 

Project → Model → Workbench LS-DYNA → Displacement 

 

Geometry – указать геометрию на 

которую прикладывается пере-

мещение; 

Define By – определение с помо-

щью компонент ли вектора; 

X, Y, Z Component – значения пе-

ремещения. 

 

Для задания скорости на требуемую геометрию применяется 

команда: 

Project → Model → Workbench LS-DYNA → Velocity 

 

Geometry – указать геометрию на 

которую прикладывается ско-

рость; 

Define By – определение с помо-

щью компонент ли вектора 

X, Y, Z Component – значения 

скорости. 
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Для ограничения только по перемещениям применяется команда 

Project → Model → Workbench LS-DYNA → Simply Supported 

 

Geometry – указать геометрию на 

которую прикладываются огра-

ничения 

 

 

Для ограничения только по вращению применяется команда 

Project → Model → Workbench LS-DYNA → Fixed Rotation 

 

Geometry – указать геометрию на 

которую прикладываются огра-

ничения на вращение 

Rotation X, Y, Z – ограничение на 

вращение по осям 

 

Для приложения ускорения на всю модель применяется команда 

Project → Model → Workbench LS-DYNA → Acceleration 

 

 

Define By – определение с помо-

щью компонент ли вектора 

X, Y, Z Component – значения 

ускорения 

 

Для приложения силы тяжести на модель применяется команда 

Project → Model → Workbench LS-DYNA → Standard Earth Gravity 

 

 

X, Y, Z Component – значения 

гравитации 

Direction – направление действия 

гравитации 
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Для приложения давление на поверхность применяется команда 

Project → Model → Workbench LS-DYNA → Pressure  

 

 

Geometry – указать плоскую гео-

метрию на которую прикладыва-

ется давление; 

Define By – определение с помо-

щью нормали, компонента или 

вектора; 

Magnitude – величина давления 

 

Для приложения гидростатического давления на поверхность 

применяется команда 

Project → Model → Workbench LS-DYNA → Hydrostatic Pressure  

 

 

Geometry – указать плоскую гео-

метрию на которую прикладыва-

ется гидростатическое давление 

Fluid Density – плотность жидко-

сти; 

Define By – определение с помо-

щью компонента или вектора; 

Magnitude – величина давления. 

 

Для приложения усилия на поверхность применяется команда 

Project → Model → Workbench LS-DYNA → Force  

 

 

Geometry – указать плоскую гео-

метрию на которую прикладыва-

ется усилие; 

Define By – определение с помо-
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щью компонента или вектора; 

Magnitude – величина усилия. 

 

Для создания жесткой стенки (Rigid Wall) применяется команда 

Project → Model → Workbench LS-DYNA → Rigid Wall 

  

 

Geometry – указать плоскую гео-

метрию относительно которой 

строится Rigid Wall; 

Coordinate System – система ко-

ординат. 

 

Для работы с Rigid телами применяются команды  

Project → Model → Workbench LS-DYNA → Rigid Body 

Rigid Body Rotation Определение вращения на Rigid теле 

Rigid Body Angular Velocity Определение угловой скорости на 

Rigid теле 

Rigid Body Force Определение усилия на Rigid теле 

Rigid Body Moment Определение момента на Rigid теле 

Rigid Body Constrain Ограничение Rigid тела 

Rigid Body Property Определение моментов инерции Rig-

id тела 

 

Для вывода дополнительных данных (например, для вывода ин-

формация по узлам) применяются Tracker: 

Project → Model → Workbench LS-DYNA → Result Tracker 

Project → Model → Workbench LS-DYNA → Body Contact Track-

er 
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1.2.7. Joints. 

 

Joints – предназначены для соединения двух жестких тел.  

Выбор Joints осуществляется из верхнего меню по кнопке Body-

Body и выбора соответствующего соединения. Например, Cylindrical 

для соединения двух цилиндров. 

 

 

 

Type - выбрать тип соединения: 

Fixed, Revolve, Translational, Slot, 

Cylindrical, Universal, Spherical, 

Planar, General, Bushing. 

 Scope – выбор геометрии (кон-

тактных плоскостей rigid геомет-

рии). 

 

Подробнее по определении цилиндрического соединения можно 

посмотреть в источнике: Workbench LS-DYNA (ACT Extension) Train-

ing. Workshop 8. Kinamatic Joints – Cylindrical. 15.0 Release. 

 

1.2.8 Контрольные карты 

Программа ansys workbench ls-dyna поддерживает основные 

контрольные карты и карты вывода. 
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Определение критерия остановки процесса расчета 

(*CONTROL_TERMINATION). 

Project → Model → Workbench LS-DYNA → Analysis setting, за-

кладка Step Controls 

 

End Time – время окончания расчета; 

Time Step Safety Factor – коэффициент 

запаса; 

Maximum Number of Cycles – максималь-

ное количество временных шагов; 

Automatic Mass Scaling – массовое скали-

рование. 

 

 

Определение временного шага (*CONTROL_TIMESTEP). 

Project → Model → Workbench LS-DYNA → Analysis setting, за-

кладка Step Controls. 

Можно задать требуемый временной шаг для выполнения мас-

сового скалирования. 

 
Automatic Mass Scaling – массовое скали-

рование; 

Time Step Size – величина временного 

шага. 

 

Определение временного шага с помощью графика 

(*CONTROL_TIMESTEP, DEFINE_CURVE) 
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Project → Model → Workbench LS-DYNA → Time step control 

  

 

Ввод табличных данных для графика 

определяющий временной шаг 

 

Определение параметров для запуска процесса на расчет 

Project → Model → Workbench LS-DYNA → Analysis setting, за-

кладка CPU and Memory Management. 

 

Memory Allocation – определение выде-

ляемой памяти для расчета*; 

Number of CPUS – количество использу-

емых процессоров; 

Processing Type – тип используемого ре-

шателя (SMP или MMP). 

* - зависит от размера конечно-элементной модели. Можно 

установить равной 250000000 или 500000000. 

 

Определение типа решателя: 

Project → Model → Workbench LS-DYNA → Analysis setting, за-

кладка Solver Controls 

 

Solver Type – тип решателя (структурный 

или структурно-тепловой); 

Solver Precision – точность решателя 

(одинарный или двойной точности); 

Unit System – система единиц. 
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Определение времени действия начальной скорости: 

Project → Model → Workbench LS-DYNA → Analysis setting, за-

кладка Initial Velocities (*VELOCITY_GENERATION 

_START_TIME). 

 

Initial Velocities are applied immediately – 

определение действия начальной скоро-

сти; 

Start Time – время начала действия. 

 

Определение глобального демпфиования: 

Project → Model → Workbench LS-DYNA → Analysis setting, за-

кладка Damping control (*DAMPING_GLOBAL) 

 

Global Damping – определение глобаль-

ного демпфирования; 

Magnitude – величина глобального демп-

фирования. 

 

Определение Hourglass control  

Project → Model → Workbench LS-DYNA → Analysis setting, за-

кладка Hourglass Controls (*CONTROL_HOURGLASS) 

 

Hourglass Type – тип Houglass; 

LS-DYNA ID – номер типа Houglass; 

Default Houglass Coefficient  – Houglass 

коэффициент. 
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Определение выходных параметров: 

Project → Model → Workbench LS-DYNA → Analysis setting, за-

кладка Output Control (*DATABASE_FORMAT, 

*DATABASE_EXTENT_BINARY, *DATABASE_BINARY_D3PLOT, 

*INTERFACE_SPRINGBACK_LSDYNA). 

 

Output Format – выходной формат фай-

лов ansys и/или ls-dyna; 

Stress – вывод напряжений; 

Strain – вывод деформаций; 

Plastic Strain – вывод пластических де-

формаций; 

Calculate Results At – сохранение резуль-

татов (определение частоты записи или 

времени сохранения); 

Value – значение; 

Stress File for flexible parts – сохранение 

выходного файла . 

 

Определение выходных параметров временной истории: 

Project → Model → Workbench LS-DYNA → Analysis setting, за-

кладка Time History Output Control (*DATABASE_ ASCII). 

 

 Calculate Results At – сохранение резуль-

татов (определение частоты записи или 

времени сохранения); 

Value – значение; 

Output – вывод ASCII файлов BNDOUT, 
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DEFGEO, DEFORC, GCEOUT, GLSTAT, 

JNTFORC, NODOUT, MATSUM, 

NCFORC, RBDOUT, RCFORC, 

RWFORC, SLEOUT, SPCFORC, 

SWFORC 

 

 

1.3.  Интеграция LS-Dyna в Ansys Workbench. 

 

Для интеграции ключевых слов программы LS-DYNA в Ansys 

Workbench могу применяться следующие команды.  

Для включения части другого k файл в данный файл использу-

ется команда: 

Project → Model → Workbench LS-DYNA → Input File Include 

 

 

Требуется указать название под-

гружаемого k файла 

 

Для ручного ввода ключевых слов используется команда:  

Project → Model → Workbench LS-DYNA → Keyword Snippet 

 

В этом случае вместо модели открывается окно Command, где 

вводятся дополнительные ключевые слова (которых нет по умолча-

нию в программе Ansys Workbench ls-dyna). 

 

 

 

Для более тщательной правки можно использовать текстовый 

редактор или другой препроцессор, например, LS-PREPOST. 
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Для этого можно использовать иконку для сохранения k-файла 

(верхнее меню). 

 

 

Однако в этом случае запуск на расчет происходит из окна про-

граммы LS-DYNA (используя менеджер LS-DYNA или с помощью 

консоли) и расчет нельзя будет посмотреть в Ansys Workbench. Но в 

этом случае можно использовать Все возможность LS-DYNA по клю-

чевым словам. 

 

1.4.  Анализ результатов в Ansys. 

 

Для вывода результатов после запуска на расчет используется 

меню Solution: 

Project → Model → Workbench LS-DYNA → Solution 

 

Вывод необходимых параметров можно осуществить, нажав ле-

вой кнопкой мыши по меню Solution → Insert. 

Программа позволяет осуществить вывод связанный с деформа-

циями: Total, Directional, Total Velocity, Directional Velocity, Total Ac-

celeration, Directional Acceleration . 

 

Вывод деформаций: 
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Вывод напряжений: Equivalent (von_Mises), Maximum Principal, 

Middle Principal, Minimum Principal, Maximum Principal, Intensity, 

Normal Shear, Vector Principal. 

 

 

Для вывода деформаций по осям координат при запуске расчета 

нужно не забыть активировать вывод деформаций: 

Project → Model → Workbench LS-DYNA → Analysis setting, за-

кладка Output Control 

 

 

Кроме этого, для точного вывода анимации нужно сделать вы-

вод в реальном масштабе. Для этого в верхнем меню нужно выбрать 

вывод результатов 1.0 (True Scale). 

 

Для вывода дополнительных данных можно использовать вывод 

User Defined Result. 
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В этом случае в окне User Defined Result доступен ввод расши-

рения Expression который означает вывод по определенному парамет-

ру. 

 

 

Узнать какое обозначение соответствует вводу в расширения 

Expression можно при помощи иконки Worksheet (Верхнее меню про-

граммы) 

 

Таблица с расширениями Expression приведена ниже 
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Данными значениями пользоваться довольно удобно. Например, 

расширение EPS осуществляет вывод по пластическим деформациям 

по Von Mises. 
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Для вывода графиков по различным параметрам (энергии, уси-

лий, контактных значений и т.п.), значения ASCII LS-DYNA исполь-

зуется команда: 

Project → Model → Workbench LS-DYNA → Analysis setting, за-

кладка Time History Output Control 

 

где Value количество точек записей (по умолчанию 1000) 

 

Примеры выходных параметров ASCII. 

• GLSTAT ( Kinetic Energy, Internal Energy, Total Energy, Hour-

glass, ....); 

• BNDOUT ( Boundary Conditions Data); 

• RCFORC ( Contact Forces Data); 

• SPCFORC ( Reaction Forces, used the *BOUNDARY_SPC ( 

Fixed Support); 

• MATSUM ( Energy Body Data); 

• NODOUT ( Nodal Data) Для вывода узловых данных 

необходимо определение Трекеров (Tracker), п.2.2.6. 

 

При анализе результатов в рабочем окне выводятся результаты 

расчета в виде сохраненных этапов. По умолчанию количество сохра-

ненных этапов 20. Изменить количество сохраненных этапов можно 

при помощи команды Project → Model → Workbench LS-DYNA → 
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Analysis setting, закладка Output Control, Calculate Results at – Equally 

Spaces Point, Value = 100 (рекомендуется пользователями ls-dyna). 

Кроме этого для сохранения напряжений для деформируемых частей 

можно установить параметр Stress File for flexible parts – Yes. 

 

Под рабочим окном выводится панель анимации (для управле-

ния и сохранения анимации). Также выводится график значений для 

снимаемого параметра для минимального, максимального и среднего 

значения и таблица с этими значениями. 

 

 

 

В результатах можно вывести значения в зонах контакта (при 

использовании Manual Contact Region). 

Вывод данных параметров можно осуществить, нажав левой 

кнопкой мыши по меню Solution → Insert 
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В случае если какие то данные не получается извлечь из сохран-

ной базы данных, то это можно сделать используя препроцессор LS-

PREPOST, бесплатно поставляемый для пользователей LS-DYNA. 

Программа ls-dyna (ansys workbench ls-dyna) может использо-

вать линейные и квадратичные элементы. Квадратичные элементы 

предполагают использование среднего дополнительного узла по реб-

ру элемента 

 

Основные виды линейных и квадратичных элементов 

Тип элемен-

та 

Линейные* Квадратичные** 

Прямо-

угольные 

shell  

 

ELFORM:=2 

 

ELFORM:=23 

6-и гранный 

solid 

 

ELFORM:=1 

 

ELFORM:=23 

4-х гранный 

solid 

 

ELFORM:=10 

 

ELFORM:=16 
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*Определение в программе Ansys Workbench ls-dyna: Project → 

Model → Mesh; Element Order – Linear. 

**Определение в программе Ansys Workbench ls-dyna: Project → 

Model → Mesh; Element Order – Linear. 

 

 

1.5. LS-Dyna: преимущества и недостатки 

 

1.5.1. Преимущества программы LS-DYNA на основе препост-

процессора LS-PREPOST 

Программа LS-DYNA на основе препостпроцессора LS-

PREPOST имеет следующие преимущества: 

- полный набор ключевых слов позволяющих решать задачи 

прочности, гидрогазодинамики, электродинамики, мультифизичные  

и другие задачи; 

- доступ ко всем настройкам и опциям программы с подробным 

описанием каждой опции; 

- простой и бесплатный препроцессор “заточненный” непосред-

ственно под программу LS-DYNA, позволяющий создавать модели 

под такие методы расчета как SPH (Smooth Particle Hydrodynamics), 

DEM (Discrete Element Method), SPG (smooth particle Galerkin) и др. 

- постпроцессор позволяет сразу после запуска расчета просмат-

ривать результаты (при запуске файла на расчет и сохранении первого 

3dplot файла результаты можно сразу просмотреть в препроцессоре 

LS-PREPOST (верхнее меню - File – Open – LS-DYNA Binary plot). В 

процессе прохождения расчета будут сохраняться новые d3plot фай-

лы, их также можно подгрузить используя Верхнее меню – File – Up-
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date. Другой вариант закрыть и открыть ls-prepost заного и загрузить 

сохраненные d3plot файлы File – Open – LS-DYNA Binary plot). 

- стоимость (стоимость программы LS-DYNA с препроцессором 

ls-prepost ниже примерно в 2,5-3 раза по сравнению с программой 

ANSYS Workbench LS-DYNA). При этом стоимость зависит на сколь-

ко ядер покупается лицензия и снижается в несколько раз при покуп-

ке начиная с 4-го ядра. 

1.5.2. Недостатки программы LS-DYNA на основе препостпро-

цессора LS-PREPOST 

Программа LS-DYNA на основе препостпроцессора LS-

PREPOST имеет следующие недостатки: 

- необходимость задавать вручную все требуемые ключевые 

слова; 

- сеточный генератор не позволяет создавать гексагональные 

(кубические, Hex) сетки для сложных объемных тел. В этом случае 

приходится использовать разбивку геометрии на более простые части 

с последующей нанесением сетки, что в ряде случаев также выдает 

ошибку. В данных случаях приходится использовать Тетраэдральную 

сетку которая требует использования большего количества элементов 

и, как правило, не рекомендуется для динамических расчетов с боль-

шими деформациями. 

 

1.6. ANSYS Workbench/LS-Dyna:  преимущества и недостатки 

1.6.1. Преимущества программы ANSYS Workbench/LS Dyna 

Программа ANSYS Workbench/LS Dyna имеет следующие пре-

имущества: 
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- упрощенный ввод параметров для расчета (характерный для 

пользователей Ansys Workbench); пример (количество кликов мыши - 

граничные условия); 

- удобный и относительно новый препостпроцессор; 

- многие ключевые слова, контрольные и выходные карты (data-

base) создаются автоматически (не нужно их вводить); 

Например, для примера 1 (со сферой) дополнительно создаются 

данные карты: 

*DATABASE_FORMAT, *CONTROL_TIMESTEP, 

*CONTROL_CONTACT, *CONTROL_ENERGY, 

*CONTROL_BULK_VISCOSITY, *CONTROL_SOLID, 

*CONTROL_SHELL, *CONTROL_OUTPUT, 

*CONTROL_PARALLEL, *CONTROL_SOLUTION, 

*CONTROL_ALE, *CONTROL_RIGID, 

*DEFINE_COORDINATE_SYSTEM, 

*DATABASE_BINARY_INTFOR 

Эти карты позволяют обеспечить вывод дополнительных пара-

метров, добавляют вязкость в модель и др. Их вывод связан с особен-

ностями создания k файла в программе ANSYS. Отдельные карты со-

держать параметры по умолчанию и не используются в расчете рас-

сматриваемых примеров. Например, карта *CONTROL_SOLUTION 

по умолчанию имеет параметр SOLN=0, что соответствует Structural 

analysis и не используется в расчете. Но при решении тепловых задач 

параметр SOLN будет заменен на 1 или 2 и тогда это учитывается 

программой. 

*DATABASE_FORMAT – позволяет указать программе для ка-

кой программы делать выходные файлы (Ansys или Ls-dyna). По 

умолчанию только LS-DYNA. 
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*CONTROL_TIMESTEP – позволяет задать вручную временной 

шаг. По умолчанию определяется автоматически. Но в данной карте 

также активирована опции ERODE = 1, что позволяет удалять эле-

менты при значительном его искажении. 

*CONTROL_CONTACT – например, сразу установлена опция 

IGNORE=2, что позволяет учитывать начальные проникновения. 

*CONTROL_ENERGY – все параметры установлены в значения 

2, что обеспечивает сохранение всей энергии процесса. 

*CONTROL_BULK_VISCOSITY – добавляет небольшую вяз-

кость в модель. 

*CONTROL_SOLID – включена опция ESORT для сортировки 

элементов (в случае применения одновременно нескольких типов 

элементов в одной части). 

*CONTROL_SHELL - включена опция ESORT для сортировки 

элементов (в случае применения одновременно нескольких типов 

элементов в одной части), активирован учет изменения толщины 

ISTUPD, добавлена жесткость в модель (параметр BWC). 

*CONTROL_OUTPUT – настройка выходных параметров. Не 

выводятся узловые координаты, начальные скорости и др. (параметр 

NPOPT). 

*CONTROL_PARALLEL – настройка количество используемых 

ядер. 

*CONTROL_ALE – настройка ALE решателя (в наших приме-

рах не используется). 

*CONTROL_RIGID – контроль Rigid тел, все параметры по 

умолчанию. 
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*DEFINE_COORDINATE_SYSTEM – определение локальной 

системы координат, по умолчанию соответствует глобальной системе 

координат. 

*DATABASE_BINARY_INTFOR – сохранение выходных дан-

ных для контактной поверхности. 

- хороший сеточный редактор (препроцессор Ansys Workbench 

имеет хорошие возможности по нанесению различных видов сеток на 

геометрию). Достаточно много литературы и видеоуроков на эту те-

му. 

Программа Ansys Workbench имеет встроенный сеточный ре-

дактор, имеющий большие возможности по нанесению качественной 

сетки. Особенностью динамических программ (к которым относится 

программа ls-dyna) является использование гексогонального (HEX) 

сетки при равномерном распределении размеров элементов по все 

модели. Программа Ansys Workbench позволяет осуществлять приме-

нение виртуальной топологии (Virturl topology) и с упрощением гео-

метрии (defeaturing) позволяющий создать сетку без жесткой привяз-

ки к границам поверхностей. 

- настройка и запуск на расчет осуществляется не выходя из 

программы ANSYS Workbench/LS Dyna; 

- В программе при наличие 2 и более тел автоматически задает-

ся контакт Connection – Body Interaction который в k файле создаст 

карту CONTACT_AUTOMATIC_SINGLE_SURFACE; 

- Программа ANSYS Workbench/LS Dyna поддерживает все но-

вые решатели ls-dyna (при наличии соответствующей лицензии). Т.е. 

можно использовать самые последние solver (решатели) от LS-DYNA. 

(С сайта LSTC скачивается последняя версия LS-DYNA, копируется в 

папку ANSYS с решателями LS-DYNA, при запуске указывается на 
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новый решатель. Также можно просто заменить файл старого решате-

ля на новый); 

- имеется возможность добавлять ключевые слова, которых нет 

в препроцессоре, также можно сохранить k-файл с последующей 

правкой в любом другом редакторе.  

Программа Ansys Workbench LS-DYNA позволяет вводить клю-

чевые слова которые отсутствуют с исходном препроцессоре. Для 

этого используется окно Keyword Snippet. В это окно можно ввести в 

текстовом виде любые ключевые слова, таким образом можно ис-

пользовать все возможности программы LS-DYNA. 

Другой вариант это создание в программе ANSYS 

Workbench/LS Dyna только сеточной геометрии и сохранением k-

файла. Далее данный файл корректируется и дополняется либо в тек-

стовом редакторе или в программе LS-PREPOST. Преимущества та-

кого способа это использование продвинутого сеточного редактора 

ANSYS, автоматического сохранения контрольных карт и дополне-

ние, чистка и правка k файла в препроцессоре поддерживающие все 

возможности ls-dyna. 

Например, при отсутствии нужной модели материала короба в 

программе ANSYS Workbench/LS Dyna в примере 3 можно придер-

живаться следующей последовательности: 

- подготовка полной модели как приведено ранее в примере 3 (в 

качестве модели материала короба вводится любая); 

- cохранение k файла через Верхнее меню – Write Solver File; 

- программа ANSYS закрывается; 

- k файл открывается в программе LS-PREPOST; 

- удаляется модель материала короба и вводится новая модель 

материала; 
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- k-файл запускается на расчет. Для этого используется про-

грамма Mechanical APDL Product Launcher, использующая лицензию 

ANSYS LS-DYNA; 

- просмотр результатов осуществляется в постпроцессоре LS-

PREPOST. 

1.6.2. Недостатки программы ANSYS Workbench/LS Dyna 

- настройки препроцессора позволяют осуществлять расчет 

только процессов деформирования твердых тел (задачи прочности, 

задачи metal forming, удара, дроп-тесты); 

- невозможность корректировки в препроцессоре ANSYS 

Workbench некоторых ключевых слов; 

- сохраняемый k файл содержит много пустых карт (ключевых 

слов); 

Сохраняемый k-файл содержит несколько ключевых слов кото-

рые не активированы и не участвуют в расчете (т.е. их можно не зада-

вать для приведенных ранее примеров). Примеры данных ключевых 

слов *DATABASE_FORMAT, *CONTROL_OUTPUT, 

*CONTROL_PARALLEL, *CONTROL_SOLUTION, 

*CONTROL_ALE, *CONTROL_RIGID 

Например ключевое слово *CONTROL_ALE не используется в 

Лагранжевом методе (который применяется во всех 3-х примерах). И 

наличие этого ключевого слова с параметрами по умолчанию не акти-

вирует метод ALE (Лагранжево-Ейлеровый метод). Поэтому это клю-

чевое слово можно не задавать 

- невозможность просмотра результатов расчета в препроцессо-

ре ANSYS Workbench до завершения расчета; 

- при определении контакта между частями модели требуется 

несколько больших действий чем в ls-prepost: сначала удаляется кон-
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такт заданный по умолчанию (Body Interaction), затем определяется 

контакт через Manual contact region, где определяется Frictionless, 

Frictional или Bonded контакт, а затем в панели Workbench LS-DYNA 

определяется Contact Properties где определяется Automatic, Forming 

или Eroding контакт/ 

 

1.7. Формулировки Shell элементов в Ansys Workbenck LS-

DYNA 

Всего используется 14 формулировок. Как видно из таблицы 

они полностью соответствуют формулировкам из LS-PREPOST. 

По умолчанию (Program Controlled) используется формулировка 

№2 

 

Formulation in Ansys 

Workbench ls-dyna 

Project – model – 

Workench ls-dyna - Sec-

tion 

LS-

DYNA 

ID 

Formulation in ls-prepost 

Model – Keyword - SEC-

TION_SHELL 

 

Program Controlled 2 Belytschko-Tsay (default) 

Hughes-Liu 1 Hughes-Liu 

Belytschko-Tsay 2 Belytschko-Tsay (default) 

BCIZ Triangular Shell 3 BCIZ triangular shell 

C0 Triangular Shell 4 C0 triangular shell 

Belytschko-Tsay 

membrane 

5 Belytschko-Tsay membrane 

S/R Hughes-Liu 6 S/R Hughes-Liu 
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S/R Co-Rotational 

Hughes-Liu 

7 S/R co-rotational Hughes-Liu 

Belytschko-Leviathan 

Shell 

8 Belytschko-Leviathan shell 

Fully Integrated Be-

lytschko-Tsay Membrane 

9 Fully integrated Belytschko-Tsay 

membrane 

Belytschko-Wong-Chiang 10 Belytschko-Wong-Chiang 

Fast (Co-Rotational) 

Hughes-Liu 

11 Fast (co-rotational) Hughes-Liu 

 12 Plane stress (x-y plane) 

 13 Plane strain (x-y plane) 

 14 Axisymmetric solid (y-axis of 

symmetry) - area weighted 

 15 Axisymmetric solid (y-axis of 

symmetry) - volume weighted 

Fully Integrated Shell 

Element 

16 Fully integrated shell element 

(very fast) 

 -16 Fully integrated shell element 

modified for higher accuracy 

 17 Fully Integrated DKT, triangular 

shell element 

 18 Fully Integrated linear DK qaudri-

lateral/triangular shell 

 20 Fully integrated linear assumed 

strain C0 shell 

 21 Fully integrated linear strain C0 



 51 

shell (5DOF) 

 22 Linear shear panel element (3 DOF 

per node) 

8-node Quadratic 

Quadrilateral Shell 

23 8-node quadrilateral shell (under 

development) 

6-node Quadratic 

Triangular Shell 

24 6-node quadratic triangular shell 

(under development) 

 25 Belytschko-Tsay shell with thick-

ness stretch 

 26 Fully integrated shell with thick-

ness stretch 

 27 C0 triangular shell with thickness 

stretch 

 29 Cohesive shell element for edge-

to-edge connection of shells. 

 -29 Cohesive shell element for edge-

to-edge connection of shells (more 

suitable for pure shear) 

 31 1 point eulerian Navier-Stokes 

 32 8 point Eulerian Navier-Stokes 

 33 CVFEM Eulerian Navier-Stokes 

 41 Mesh-free (EFG) shell local ap-

proach. (more suitable for crash-

worthiness analysis) 

 42 Mesh-free (EFG) shell global ap-

proach. (more suitable for metal 
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forming analysis) 

 43 Mesh-free (EFG) plane strain for-

mulation (x-y plane) 

 44 Mesh-free (EFG) axisymmetric 

solid formulation (x-y plane, y-axis 

of symmetry) 

 46 Cohesive element for two-

dimensional plane strain, plane 

stress, and area-weighted axisym-

metric problems (type 14 shells) 

 47 Cohesive element for two-

dimensional volume-weighted ax-

isymmetric problems (use with 

type 15 shells) 

В ls-prepost на данный момент 38 формулировок карты Shell 

 

1.8. Формулировки Solid элементов в Ansys Workbenck LS-

DYNA. 

Всего используется 12 формулировок. Как видно из таблицы 

они практически полностью соответствуют формулировкам из LS-

PREPOST. 

По умолчанию (Program Controlled) используется формулировка 

№1 

Formulation in Ansys 

Workbench ls-dyna 

Project – model – 

Workench ls-dyna - 

LS-

DYNA 

ID 

Formulation in ls-prepost 

Model – Keyword - SEC-

TION_SOLID 
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Section 

Program Controlled 1 constant stress solid element (default) 

1 Point Corotational 0 1 point corotational 

Constant Stress Solid 

Element 

1 constant stress solid element (default) 

Fully Integrated S/R 

Solid 

2 fully integrated S/R solid 

Fully Integrated Quad-

ratic 8 node Element 

with Nodal Rotations 

3 fully integrated quadratic 8 node ele-

ment with nodal rotations 

S/R Quadratic 

Tetrahedron 

4 S/R quadratic tetrahedron element 

with nodal rotations 

 5 1 point ALE 

 6 1 point Eulerian, 

 7 1 point Eulerian ambient, EQ.8: 

acoustic, 

 9 1 point corotational for 

*MAT_MODIFIED_HONEYCOMB, 

1 point tetrahedron 10 1 point tetrahedron 

 11 1 point ALE multi-material element, 

 12 1 point integration with single materi-

al and void, 

1 point Nodal Pressure 

Tetrahedron 

13 1 point nodal pressure tetrahedron for 

bulk forming 

 14 8 point acoustic 
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2 point Pentahedron 

Element 

15 2 point pentahedron element 

4 or 5 point 10-noded 

Tetrahedron 

16 5 point 10 noded tetrahedron 

10-noded Composite 

Tetrahedron 

17 10-noded composite tetrahedron 

Poor Aspect Ratio, Ful-

ly Integrated S/R Solid 

, Accurate Formulation 

-2 fully integrated S/R solid intended for 

elements with poor aspect ratio, accu-

rate formulation. 

Poor Aspect Ratio, Ful-

ly Integrated S/R Solid 

, Efficient Formulation 

-1 fully integrated S/R solid intended for 

elements with poor aspect ratio, effi-

cient formulation 

 18 8 point enhanced strain solid element 

for linear statics only, 

 19 4 point cohesive element, 

 20 4 point cohesive element with offsets 

for use with shells, 

 21 6-noded, 1 point pentahedron cohe-

sive element 

 22 6-noded, 1 point pentahedron cohe-

sive element with offsets for use with 

shells. 

 23 20-node hexahedron formulation. 

 24 27-node hexahedron formulation. 

 25 21-node pentahedron formulation 

 26 15-node tetrahedron formulation 
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 41 Mesh-free (EFG) solid formulation 

 42 Adaptive 4-noded mesh-free (EFG) 

solid formulation 

 43 Mesh-free enriched finite element 

 45 Tied Mesh-free enriched finite ele-

ment 

 47 Smoothed particle Galerkin method 

 98 Interpolation solid 

 99 Simplified linear element for time-

domain vibration studies, 

 101 User defined solid. 

 115 1 point pentahedron element with 

hourglass control. 

 201 Isogeometric solids with NURBS 

В ls-prepost на данный момент 38 формулировок карты Solid 

 

1.9. Модели материалов доступные в Ansys Workbenck LS-DYNA 

Номер материа-

ла 

Наименование 

Mat1 MAT_ELASTIC 

Mat2 MAT_ORTHOTROPIC_ELASTIC 

Mat3 MAT_PLASTIC_KINEMATIC 

Mat7 MAT_BLATZ-KO_RUBBER 

Mat15 MAT_JOHNSON_COOK 
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Mat18 MAT_POWER_LAW_PLASTICITY 

Mat20 MAT_RIGID 

Mat24 MAT_PIECEWISE_LINEAR_PLASTICITY 

MAT36 MAT_3-PARAMETER_BARLAT 

MAT37 MAT_3-PARAMETER_BARLAT 

Mat57 MAT_LOW_DENSITY_FOAM 

Mat77 MAT_HYPERELASTIC_RUBBER, 

MAT_OGDEN_RUBBER 

Mat98 MAT_SIMPLIFIED_JOHNSON_COOK 

Mat123 MAT_MODIFIED_PIECEWISE_LINEAR_PLASTICITY 

Mat140 MAT_VACUUM 

T01 MAT_THERMAL_ISOTROPIC 

MAT 

ADD_EROSION 

MAT_ADD_EROSION 

В ls-prepost на данный момент 336 моделей материалов (вклю-

чая модели разрушения, тепловые модели, демпферы и т.п.) 

 

1.10. Формулировки Hourglass в Ansys Workbenck LS-DYNA 

Всего используется 7 формулировок. Как видно из таблицы они 

практически полностью соответствуют формулировкам из LS-

PREPOST. 

По умолчанию (Program Controlled) используется формулировка 

№1 

Formulation in Ansys 

Workbench ls-dyna 

LS-

DYNA 

Formulation in ls-prepost 
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Project – model – 

Workench ls-dyna - 

Hourglass 

ID Model – Keyword - Hourglass 

 

Program Controlled 1 standard LS-DYNA viscous form 

Standard LS-DYNA 1 standard LS-DYNA viscous form 

Flanagan-Belytschko 

Viscous Form 

2 Flanagan-Belytschko viscous form 

Exact Volume Flanagan-

Belytschko 

3 Flanagan-Belytschko viscous form 

with exact volume integration for 

solid elements 

Flanagan-Belytschko 

Stiffness Form 

4 :Flanagan-Belytschko stiffness 

form 

Exact Volume Flanagan-

Belytschko Stiffness Form 

5 Flanagan-Belytschko stiffness 

form with exact volume integra-

tion for solid elements 

Belytschko-Bindeman 6 Belytschko-Bindeman assumed 

strain co-rotational stiffness form 

for 2D and 3D solid elements only 

Belytschko-Bindeman 

Linear Total Strain 

7 Linear total strain form of type 6 

hourglass control 

 8 Applicable to the type 16 fully in-

tegrated shell element 

 9 Puso enhanced assumed strain 

stiffness form for 3D hexahedral 

elements. 

 10 Cosserat Point Element (CPE) de-

veloped by Jabareen and Rubin 
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and Jabareen et.al. 

В ls-prepost на данный момент 10 формулировок Hourglass 

 

1.11. Контакты в Ansys Workbenck LS-DYNA 

Ansys Workbench ls-

dyna 

Путь в меню  

Project → Model 

Project → Workbench 

LS-DYNA 

LS-PREPOST 

Model – Keyword – CONTACT 

 

Body Interaction CONTACT_AUTOMATIC_SINGLE_SURFACE 

Body Interaction 

Contact properties: 

Type - General 

CONTACT_AUTOMATIC_GENERAL 

Body Interaction 

Contact properties: 

Type - Eroding 

CONTACT_ERODING_SINGLE_SURFACE 

Frictionless (Friction-

al), Behavior – Pro-

gram Controlled (or 

Symmetric) 

CONTACT_AUTOMATIC_SURFACE _ TO _ 

SURFACE 

Frictionless (Friction-

al), Behavior – Pro-

gram Controlled (or 

Symmetric) 

Contact properties: 

Type - Eroding 

CONTACT_ERODING_SURFACE _ TO _ 

SURFACE 

Frictionless (Friction-

al), Behavior – Pro-

gram Controlled (or 

CONTACT_FORMING _SURFACE _ TO _ 

SURFACE 

  



 59 

Symmetric) 

Contact properties: 

Type - Forming 

Frictionless (Friction-

al), Behavior – 

Asymmetric 

CONTACT_AUTOMATIC_NODES _ TO _ 

SURFACE 

Frictionless (Friction-

al), Behavior – 

Asymmetric 

Contact properties: 

Type - Eroding 

CONTACT_ERODING _NODES _ TO _ SUR-

FACE  

Frictionless (Friction-

al), Behavior – 

Asymmetric 

Contact properties: 

Type - Forming 

CONTACT_FORMING _ONE_WAY_ 

SURFACE _ TO _ SURFACE 

Bonded CONTACT_TIED_SURFACE _ TO _ SUR-

FACE_ OFFSET 

Bonded, Behavior – 

Asymmetric 

 

CONTACT_TIED_NODES_ TO _ SURFACE_ 

OFFSET 

Bonded, Breakable – 

Stress Criteria 

 

CONTACT_ AUTOMATIC_SURFACE _ TO _ 

SURFACE_ TIEBREAK 

Behavior – Asymmet-

ric 

Breakable – Stress 

Criteria 

CONTACT_ AUTOMATIC_ ONE_WAY_ 

SURFACE _ TO _ SURFACE_ TIEBREAK 

В ls-prepost на данный момент 142 карт контакта 

1.12. Формулировки Beam в Ansys Workbenck LS-DYNA. 
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Всего используется 6 формулировок. Как видно из таблицы они 

полностью соответствуют формулировкам из LS-PREPOST. 

По умолчанию (Program Controlled) используется формулировка 

№1 

Formulation in Ansys 

Workbench ls-dyna 

Project – model – 

Workench ls-dyna - Sec-

tion 

LS-

DYNA 

ID 

Formulation in ls-prepost 

Model – Keyword - SEC-

TION_SHELL 

 

Program Controlled 1 Hughes-Liu with cross section in-

tegration (default) 

Hughes-Liu With Cross 

Section Integration 

1 Hughes-Liu with cross section in-

tegration 

Belytschko-Schwer Re-

sultant Beam 

2 Belytschko-Schwer resultant beam 

(resultant) 

Truss 3 truss (resultant) 

Hughes- Schwer Full 

Cross Section Integration 

4 Belytschko-Schwer full cross-

section integration 

Belytschko-Schwer Tubu-

lar Beam with Cross Sec-

tion Integration 

5 Belytschko-Schwer tubular beam 

with cross-section integration 

Discrete Beam/Cable 6 discrete beam/cable 

 7 2D plane strain shell element (xy 

plane) 

 8 2D axisymmetric volume weighted 

shell element (xy plane) 
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 9 spotweld beam, see 

*MAT_SPOTWELD (Type 100). 

 11 Integrated warped beam. 

 12 resultant warped beam 

 13 Small displacement, linear Timo-

shenko beam with exact stiffness. 

 14 Integrated tubular Elbow element. 

User defined integration rule with 

tubular cross section (9) must be 

used. 

В ls-prepost на данный момент 13 формулировок карты Beam 

 

1.13. Формулировки Discrete в Ansys Workbenck LS-DYNA. 

Формулировки в данном типе элемента отсутствуют. 

Тип элемента Discrete (Spring33) определяемый в Ansys Work-

benck LS-DYNA соответствует карте *Section_discrete в ls-prepost. 
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Приложение 1 

Пример моделирования процесса удара сферы об пластину в про-

грамме ANSYS WORKBENCH LS-DYNA. 

 

Исходные данные: 

Радиус сферы 3 мм, толщина сферы 0,1 мм. 

Размеры пластины 10х10 мм, толщина 0,1 мм. 

Расстояние от пластины до центра сферы 6 мм. 

Начальная скорость движения сферы 10000 мм/сек 

Материал сферы и пластины сталь (модуль Юнга 210000 H/мм
2
, ко-

эффициент Пуассона 0,3, плотность 7,85 т/мм
3
) 

Время расчета 0,002 сек. 

Для создания модели используется препостпроцессор ANSYS 19.0. 

Для расчета использовался решатель LS-DYNA smp s R8.1.0 встроен-

ный в ANSYS 

 

Рис. 1. Модель процесса удара сферы о пластину 
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Шаг 1 

Выбрать приложение Ansys ls-dyna workbench 

Выпадающее меню Extensions – Manage Extensions 

 

 

Поставить галочку на пункте LS-DYNA. 

Нажать Close 
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Выбрать закладку Workbench LS-DYNA в окне Toolbox 

 

 

Шаг 3 

Выбрать систему измерения 

Выпадающее меню - Units – Metric (tonne, mm, s) 
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Выбрать закладку Workbench LS-DYNA в окне Toolbox 

Шаг 4 

Определить параметры моделей материалов 

Окно Workbench LS-DYNA - Engineering Data 
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Шаг 5 

Определить новый материал 

В окне Engineering Data добавить новый материал “New steel” 

 

 

Шаг 6 

Определить набор характеристик материала 

В окне Toolbox выбрать пункты Density и Isotropic Elasticy 

 



 67 

Шаг 7 

Ввести параметры материала 

Density=7.,85e-9 

Young`s Modulus = 2,1e5 

Poisson`s Modulus=0,3 

 

Шаг 8 

Выйти из закладки Engineering Data 

Верхний ряд закладок - Project 

 

 

 

 

 

Шаг 9 

Создание геометрической модели 
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Выбираем опцию Geometry. Правой кнопкой выбираем New Design 

Modeler Geometry 

 

Шаг 10 

Выбор системы измерения 

Верхнее выпадающее меню – Units - Millimeter 

 

 

Шаг 11 

Построение плоскости 

В окне Tree Outline выбираем плоскость XYPlane и нажимаем кнопку 

сделать этот вид Look At Face 
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Шаг 12 

Построить произвольный прямоугольник.   

Закладка Draw – Sketching – Rectangle 

 

Строим в окне Graphics произвольный прямоугольник 

 

Шаг 13 

Нанести размеры на прямоугольник 

Закладка Dimensions – Semi-Automatic 

На прямоугольнике расставляем размеры. 
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Шаг 14 

Определяем размеры прямоугольника 

В окне Details View корректируем размеры на заданные исходным за-

данием (5, 10, 10, 5 мм). 

 

 

 

Шаг 15 

Построить поверхность на основе границ прямоугольника 

Выбрать эскиз Sketch1.  

Выпадающее меню Concept – Surfaces from Sketches – Aplly.  

Выбрать SurfaceSK2 и нажать Generate. 
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Шаг 16 

Построение сферы 

Выбрать плоскость YZPlane и показать этот вид Look At Face 
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Шаг 17 

Создать эскиз на этой плоскости 

Нажать на иконку эскиз 

 

 

Шаг 18 

Построить окружность произвольного радиуса.  

Закладка Draw – Sketching – Circle 

Строим в окне Graphics окружность произвольного размера 
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Шаг 19 

Нанести размеры 

Закладка Dimensions – Semi-Automatic 

 

 

Шаг 20 

Ввести необходимые размеры окружности 

Диаметр D1 6 мм 

Расстояние от цента V2 6 мм 

 

 

Шаг 21 

Отрезать половину окружности.  
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Sketching – Modify – Trim 

Указать на левую часть окружности 

 

 

 

Шаг 22 

Создать сферу на основе этой окружности 
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Выбрать эскиз Sketch2.  

Нажать Revolve.  

Нажать Axis – указать ось Z – Aplly.  

Нажать Generate. 

 

Шаг 23 

Выйти из программы Design Modeler 

 

Шаг 24 

Сохранить проект 
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Шаг 25 

Выбрать закладку Model 

 

 

Шаг 26 

Project - Model - Geometry 

Задать толщину для обоих тел Surface Body (по 0,1 мм) 

 

Thickness=0.1                                                Thickness=0.1 
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Шаг 28 

Определить материал для обоих тел 

     

Assignment – New steel                                      Assignment – New steel 
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Шаг 29 

Сгенерировать сетку на пластине и сфере 

Панель инструментов Mesh – Generate Mesh  

 

 

 

Шаг 30 

Определить время завершения расчета 

В окне Outline  

Analysis Setting в окне Details ввести End Time = 0,002 
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Шаг 31 

Ограничить края пластины 

В окне Outline 

Workbench ls-dyna правой кнопкой выбрать Insert – Fixed Support 
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Шаг 32 

Активировать выбор при помощи линий 

   

Выбрать Single Select 

 

 

 

Шаг 33 

Выбрать поочередно 4 грани пластины (используя кнопку Cntr клавиа-

туры) 
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Нажать Apply 

 

Шаг 34 

Определить параметры контакта 

В окне Outline 

Workbench ls-dyna правой кнопкой выбрать Insert – Contact Propertis 

В окне Details of “Contact Properties” в пункте Contact указать Body In-

teraction 
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Шаг 35 

Определить начальную скорость движения сферы 

В окне Outline  

Workbench ls-dyna – Initial Condition правой кнопкой выбрать Insert – 

Velocity 
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Шаг 36 

Активировать выбор объемного тела 

 

Указать на сферу 

В окне Details в пункте Geometry нажать Apply 

 

Шаг 37 

Определить вид ввода скорости 

Указать ввод при помощи Components 

Define By - Components 
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Шаг 38 

Ввести значения начальной скорости 

Z Component = -10000 

 

 

Шаг 39 

Определить контроль искажения Hourgalss 

Project - Model – Workbench LS-DYNA – Analysis Settings 
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В окне Details of “Analysis Settings” выбрать Hourglass Type – Flanagan-

Belyscjko Stiffness Form 

Шаг 40 

Определить коэффициент искажения Hourglass 

Ввести коэффициент Default Hourglass Coefficient = 0,05 
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Шаг 41 

Определить выходные параметры – полная деформация 

В окне Outline 

Solution – Insert - Deformation – Total  

 

 

Шаг 42 

Определить выходные параметры – напряжение 

В окне Outline 

Solution – Insert  – Stress – Equivalent (von Mises) 
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Шаг 43 

Запуск на расчет 

 

 

Шаг 44 

Просмотр результатов по напряжению 

В окне Outline 

Solution – Equivalent Stress 
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Шаг 45 

Показ в реальном масштабе 

Установить значение Result = 1.0 (True Scale) 
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Шаг 46 

Вывод анимации используя панель анимации 

 

 

 

Шаг 47 

Вывод графика с анимации 

 

 

Шаг 48 

Вывод отчета 

На рабочем экране нажать закладку Report Preview 
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Анализ результатов 

Анализ результатов был проведен в программах Ansys Work-

bench ls-dyna и LS-Prepost. 

 

Анализ результатов в постпроцессоре Ansys Workbench 
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Рис. 2. Этапы удара сферы о пластину по Von-mises stress по времени 

 

   

   

 

Рис. 3. Палитра перемещения по пластине вдоль оси Z по времени 

 

 

 

Рис. 4. График перемещений (максимальные, средние и минимальные 

значения) узлов пластины вдоль оси Z 
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Рис. 5. График перемещений (максимальные, средние и минимальные 

значения) узлов сферы по оси Z 

 

 

 

Рис. 6. График скорости движения сферы по оси Z (максимальные, 

средние и минимальные значения) 
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Рис. 7. Напряжение на пластине по Von-mises stress от удара сферой 

(максимальные, средние и минимальные значения) 

 

 

 

 

Рис. 8. Кинетическая энергия движения сферы (файл Matsum) 
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Рис. 9. Внутренняя энергия пластины  (файл Matsum) 

 

 

Рис. 10. Усилие в зоне взаимодействия сферы и пластины (файл 

Rcforc) 

 

 

Рис. 11. Усилие реакции в зоне закрепления (файл SPCForce) 



 95 

 

 

Рис. 12. Нормальное напряжение в зоне контакта 

 

Рис. 13. Касательное напряжение в зоне контакта 
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Рис. 14. Контактное усилие по узлам 

 

Сфера движется по оси Z вертикально вниз со скоростью 10000 

мм/сек. В момент времени 2,8e-4 секунды сфера ударяется об пласти-

ну. Пластина прогибается на максимальную величину 0,281 мм при 

времени 3,4e-4 сек. Потом сфера начинает движение вертикально 

верх. Максимальное напряжение по Von-mises stress составляет 2472 

МПа и соответствует моменту времени 3,4e-4 сек. 

Кинетическая энергия сферы в начальный момент времени со-

ответствует 4,4061 mJ в момент удара практически падает до нуля 

(значение 1,594e-2 mJ) и потом возрастает до 4,1 mJ. Часть кинетиче-

ской энергии переходит в внутреннюю энергию в момент удара о 

пластину. 

Внутренняя энергия на пластине возрастает до 3,513 mJ в мо-

мент удара сферы и далее уменьшается примерно до 0,15 mJ. Присут-

ствие внутренней энергии после окончания удара связано с колебани-

ями пластины. Часть внутренней энергии идет и на деформирование 

сферы. 
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После удара сфера перемещается вверх по оси Z со средней ско-

ростью 9620 мм/сек 

Усилие в момент максимального прогиба пластины соответ-

ствует величине 55,744 N. Усилие реакции в зоне фиксации края пла-

стины соответствует значению 63 N. 

Нормальное давление в зоне контакта соответствует 46,621 

МПа. 

Касательное напряжение в зоне контакта соответствует 4,7 МПа. 

 

Сравнение обработки результатов в программах ansys workbench 

ls-dyna и ls-prepost показал что результаты в основном аналогичные. 

Отличие связано: 

1. В различие исходных k файлов. Программа ansys work-

bench ls-dyna имеет большее количество параметров по 

умолчанию повышающих (по мнению разработчиков) 

точность расчета. 

2. Небольшой разнице во временных параметрах в про-

граммах. Из-за дискретной записи результаты имеют 

различия. 

3. В некоторых случаях графики имеют пилообразный вид, 

при котором оценить точно среднюю величину сложно. 

4. Программы немного по-разному обрабатывают и выво-

дят сохраненные данные при расчете. 

5. При оценке максимального напряжения отличие связано 

с визуализацией результатов 

6. Отсутствие данных по давлению в ls-prepost связано с 

отсутствием этих карт в k файле созданному в  ls-prepost. 

Ansys сохраняет их автоматически 
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Приложение 2 

Пример моделирования процесса деформирования короба об пла-

стину в программе ANSYS WORKBENCH LS-DYNA 

 

Исходные данные: 

Короб с размерами 30х30х200 мм имеет 2 открытые стороны по 

размеру 30х30. Короб по граням имеет радиуса скругления 2,5 мм. 

Толщина стенок короба 1,5 мм. 

Короб полностью ограничен по стороне 30х30 (сверху). 

Пластина с размерами 50х50х1 давит на короб по другой откры-

той стороне 30х30 (снизу) со скоростью 5000 мм/сек. 

 

Материал короба – Алюминий 1050 (модуль Юнга 69000 H/мм
2
 

(E). коэффициент Пуассона ( ) 0,33, плотность 2,7 т/мм
3
 (  ), предел 

текучести 28,06 МПа ( Y ), касательный модель 184,5 МПа (Etan) 

Время расчета 0,01 сек. 

 

Определить деформацию короба в процессе взаимодействия с 

пластиной. 

 

Для создания модели используется препостпроцессор ANSYS 

19.0. Для расчета использовался решатель LS-DYNA smp s R8.1.0 

встроенный в ANSYS 

 

 



 99 

 

Модель процесса деформирования короба об пластину 

 

 

1. Запускаем программу Ansys workbench 

 

2. Выбираем расширение ANSYS LSDYNA. 

 

Выпадающее верхнее меню Extensions – Manage Extensions 
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Ставим галочку по ls-dyna.  

Нажимаем Close. 

 

В панели Tollbox выбираем меню Workbench LS-DYNA. 
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Появляется панель Workbench LS-DYNA. 

 

 

3. Создание геометрии 

 

Выбираем опцию Geometry. Правой кнопкой выбираем New Design 

Modeler Geomerty 
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Выбираем систему единиц – мм. 

 

 

 

4. Построение короба 

 

В окне Tree Outline выбираем плоскость XYPlane и нажимаем кнопку 

сделать этот вид. 
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В окне Tree Outline выбираем закладку Sketching. 

 

 

В закладке Draw выбираем построение прямоугольника Rectangle. 

Ставим галочку на введении скругления Auto-Fillet. 
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Строим в окне Graphics произвольный прямоугольник. 

 

Выбираем закладку Dimensions – Semi-Automatic для проставления 

размеров. 
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На прямоугольнике расставляем размеры. 

 

В окне Details View корректируем размеры на заданные исходным за-

данием (15, 25, 25, 2.5, 15 мм). 
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Нажимаем кнопку Generate. 

 

На панели нажимаем кнопку Extrude (для вытягивании геометрии). 

 

Выбираем построенный эскиз Sketch1, указываем длину FD1=200, 

указываем получение тонкостенного элемента (As Thin/Surface - Yes), 

толщиной 0, FD2=0 
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Нажимаем кнопку Generate. 

 

5. Построение пластины  

 

Создаем дополнительную плоскость, на которой будем строить пла-

стину. 

 

Верхнее меню – Greate – New plane. 

 

В окне Detail View Transform1=Offset Z на расстоянии 2 мм вниз по Z 

(FD1=-2) 
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Нажимаем кнопку Generate. 

В окне Tree Outline выбираем Plane5. Показать заданный вид. 

 

 

 

В закладке Draw выбираем построение прямоугольника Rectangle. 

Убрать галочку на введении скругления Auto-Fillet. 
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Строим в окне Graphics произвольный прямоугольник. 

 

Выбираем закладку Dimensions – Semi-Automatic для проставления 

размеров. 
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На прямоугольнике расставляем размеры. 

 

В окне Details View корректируем размеры на заданные исходным за-

данием (25, 50, 50, 25). 

 

Нажимаем кнопку Generate. 

 

Построение пластины на основе созданной геометрии. 
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Выбираем Sketch2, верхнее меню Concept – Surface From Sketches. 

 

В окне Detail View нажать Apply. 

 

Нажимаем кнопку Generate. 

Закрыть программу Design Modeler 

 

Выбираем нужную систему измерения Metric (tonne, mm, s) 
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6. Определяем параметры материала 

 

В окне Workbench ls-dyna выбираем Engineering Data 

 

Выбираем нужную систему измерения Metric (tonne, mm, s) 
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7. Определяем параметры материала для пластины 

 

В окне Outline of Schematic добавляем новый материал New Steel. 

 

В закладке Toolbox выбираем пункт Density и Isotropic Elasticity. 
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Вводим значения в окне Properties of Outline Row: Density = 7,85e-9, 

Young`s Modulus = 2e5, Poisson`s Ratio = 0,3. 

 

 

8. Определяем параметры материала для короба 

 

 

В окне Outline of Schematic вводим новый материал Al 1050 
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В окне Toolbox выбираем пункт Density, Isotropic Elasticity и Bilinear 

Isotropic Hardening 

 

Вводим значения в окне Properties of Outline Row: Density = 2,7e-9, 

Young`s Modulus = 69000, Poisson`s Ratio = 0,33, Yield strength = 28,06, 

Tangent Modulus 184,5. 
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Закрываем закладку Engineering Data. 

 

9. Определение параметров модели 

 

В окне Workbench ls-dyna выбираем Model. 

 

Проверяем систему единиц. 

Выпадающее меню Units – Metric (mm, t, N, s). 

 

В окне Outline  

 

10. Определяем параметры для короба 

 

Project - Model - Geometry 
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Выбираем Surface Body (подсвечивается короб) 

в окне Surface Body вводим  

толщину Thickness=1,5 

Stiffness Behavior – Flexible 

Assignment – Al 1050 
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11. Определяем параметры для пластины 

 

Выбираем следующий Surface Body (подсвечивается пластина) 

 

в окне Surface Body вводим 

толщину Thickness=1  

Stiffness Behavior – Rigid 

Assignment – New Steel 
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12. Нанесение сетки 

 

Выбираем закладку Mesh в окне Outline 

 

В панели инструментов выбираем Mesh Control – Sizing 

 

В окне выбора выбрать 3D тела и Box Select. 

       

Выбрать окном всю модель. 

В окне Detail of Body Sizing ввести значения Element Size = 1 

 

На панели выбрать Mesh – Generate Mesh 
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13. Определение времени окончания 

 

В окне Outline  

Analysis Setting в окне Details ввести End Time = 0.01 

 

 

14. Ограничение края короба 

 

В окне Outline 

Workbench ls-dyna правой кнопкой выбрать Insert – Fixed Support 



 121 

 

В панели выбора выбрать ребра, Box Select . 

   

 

Окном выбрать грани которые нужно зафиксировать 

 

 

В окне Details нажать Apply 
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15. Ограничение пластины 

 

В окне Outline  

Workbench ls-dyna правой кнопкой выбрать Insert – Rigid Body Con-

straint 

 

В окне выбора активировать выбор 3D объектов, single Select. 

  

Выбрать окном плоскость. 

В окне Details в пункте Geometry нажать Apply 

Z Component – Free 
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16. Определение скорости на пластине 

 

 

В окне Outline  

Workbench ls-dyna правой кнопкой выбрать Insert – Velocity 

 

Выбрать плоскость 

В окне Details в пункте Geometry нажать Apply 

Z Component = 5000 
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17. Определение выходных параметров 

 

Выходные параметры по полному перемещению 

 

В окне Outline 

Solution – Insert - Deformation – Total  

 

 

Выходные параметры по напряжению 

В окне Outline 

Solution – Insert  – Stress – Equivalent (von Mises) 
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18. Сохранение проекта 

 

Сохранить проект File – Save Project 

 

 

 

19. Запуск на расчет 

 

На панели нажать кнопку Solve 
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После завершения расчета 

 

20. Просмотр результатов  

 

Просмотр по полным перемещениям 

 

В окне Outline  

Solution – Total Deformation 

 

 

 

Просмотр по напряжениям 

 

В окне Outline 

Solution – Equivalent Stress 
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Запуск анимации процесса 

Панель анимации 

 

 

Анализ результатов 

 

Анализ результатов был проведен в программах Ansys Work-

bench ls-dyna и LS-Prepost. 

Анализ результатов в постпроцессоре Ansys Workbench 
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a b c 

 
 

 

d i f 

 

Рис. 2. Этапы смятия короба пластиной по параметру Von-mises stress 

в плоскости XZ по времени: a – 0; b – 2e-3 сек; c – 4e-3 сек; d – 6e-3 

сек; i – 8e-3 сек; f – 1e-2 сек 

 

 

  

a b 
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c d 

  

i f 

 

Рис. 3. Этапы смятия короба пластиной по параметру Von-mises stress 

в плоскости YZ по времени: a – 0; b – 2e-3 сек; c – 4e-3 сек; d – 6e-3 

сек; i – 8e-3 сек; f – 1e-2 сек 

 

 

Рис. 4. График напряжений по Von-mises (максимальные, средние и 

минимальные значения)  
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a b c 

   

d i f 

 

 

Рис. 5. Этапы смятия короба пластиной по пластическим деформаци-

ям в плоскости XZ по времени: a – 0; b – 2e-3 сек; c – 4e-3 сек; d – 6e-3 

сек; i – 8e-3 сек; f – 1e-2 сек 

 

 

  

a b 
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c d 

  

i f 

 

Рис. 6. Этапы смятия короба пластиной по пластическим деформаци-

ям в плоскости YZ по времени: a – 0; b – 2e-3 сек; c – 4e-3 сек; d – 6e-3 

сек; i – 8e-3 сек; f – 1e-2 сек 
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Рис. 7. График по пластическим деформациям (максимальные, сред-

ние и минимальные значения)  

 

 

 

 

Рис. 8. Внутренняя энергия деформирования короба  (файл Matsum) 

 

 

Пластина деформирует короб, при этом максимальное напряже-

ние Von-mises составляет 229,74 МПа, а максимальная деформация 

1,325. Внутренняя энергия увеличивается от 0 до 2,535e5 mJ. 
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Контрольные карты 

 

*CONTROL_CONTACT 

 

Card 1 

● SLSFAC = 0 (default = 0.1). Scale factor for sliding interface penalties. 

● RWPNAL = 0. Scale factor for rigid wall penalties. When equal to 0 the 

constraint method is used 

and nodal points which belong to rigid bodies are not considered. 

● ISLCHK = 1. Initial penetration check in contact surfaces. When set to 

1 there is no checking. 

● SHLTHK = 1 (default). Shell thickness considered in surface to surface 

and node to surface 

contact types. When set to 1, thickness is considered but rigid bodies are 

excluded. 

● PENOPT = 1 (default). Penalty stiffness value option. 

● THKCHG = 0 (default). 

● ORIEN = 2. Automatic reorientation for contact segments during initial-

ization. When set to 2 it is 

active for manual (segment) and automated (part) input. 

● ENMASS = 0 . 

This parameter regulates the treatment of the mass for eroded nodes in con-

tact. When set to 0 

eroding nodes are removed from the calculation. 
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Card 2 

● USRSTR = 0. Storage per contact interface for user supplied interface 

control subroutine. When 

set to 0 no input data is read and no interface storage is permitted in the 

user subroutine. 

Default values are used for all other parameters. 

 

Card3 

● SFRIC = 0. Default static coefficient of friction. 

Default values are used for all other parameters. 

 

Card4 

● IGNORE = 2. Specifies whether to ignore initial penetrations in the 

*CONTACT_AUTOMATIC 

options. When set to 2 initial penetrations are allowed to exist by tracking 

them. Also warning 

messages are printed with the original and the recommended coordinates of 

each slave node. 

● FRCENG = 1. Calculate frictional energy in contact. Convert mechani-

cal frictional energy to 

heat when doing a coupled thermal-mechanical problem. 

● SKIPRWG = 0 (default). 

● OUTSEG = 1. Yes, output each beam spot weld slave node and its mas-

ter segment for 

*CONTACT_SPOTWELD into D3HSP file. 
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● SPOTSTP = 0 (default). 

● SPOTDEL = 1.Yes, delete the attached spot weld element if the nodes 

of a spot weld beam or 

solid element are attached to a shell element that fails and the nodes are 

deleted. 

SPOTHIN = 0.5. This factor can be used to scale the thickness of parts 

within the vicinity of the spot weld. 

 

This factor helps avert premature weld failures due to contact of the weld-

ed parts with the weld itself. 

Should be greater than zero and less than one. 

 

*CONTROL_ENERGY 

 

Specifies the controls for energy dissipation options. 

 

Card 

● HGEN = 2. Hourglass energy is computed and included in the energy 

balance. Results are 

reported in ASCII files GLSTAT and MATSUM. 

● RWEN = 2 (default). 

● SLNTEN = 2. Sliding interface energy dissipation is computed and in-

cluded in the energy balance. 

Results are reported in ASCII files GLSTAT and SLEOUT. 
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● RYLEN = 2. Rayleigh energy dissipation is computed and included in 

the energy balance. Results 

are reported in ASCII file GLSTAT. 

 

*CONTROL_ACCURACY 

 

Specifies control parameters that can improve the accuracy of the calcula-

tion. 

 

Card 

● OSU = 1. Global flag for objective stress updates. Required for parts that 

undergo large rotations. 

When set to 1 the flag is on. 

● INN = 4. Invariant node numbering for shell and solid elements. When 

set to 4 the flag is on for 

both shell and solid elements. 

 

*CONTROL_BULK_VISCOSITY 

 

Sets the bulk viscosity coefficients globally. 

 

Card 

● Q1 = 1.5 (constant) Quadratic Artificial Viscosity. 

● Q2 =0.06 (constant) Linear Artificial Viscosity . 
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● TYPE = -2. Internal energy dissipated by the viscosity in the shell ele-

ments is computed and 

included in the overall energy balance. 

 

*CONTROL_SOLID 

Specifies global parameters for solid element types. 

 

Card 

● ESORT = 1, full automatic sorting of tetrahedron and pentahedron ele-

ments to treat 

degeneracies. Degenerate tetrahedrons will be treated as ELFORM = 10 

and pentahedron as 

ELFORM = 15 solids respectively (see *SECTION_SOLID). 

 

*CONTROL_SHELL 

 

Specifies global parameters for shell element types. 

 

Card 

● WRPANG = 20 (default). Shell element warpage angle in degrees. If a 

warpage greater 

than this angle is found, a warning message is printed 

● ESORT = 1, full automatic sorting of triangular shell elements to treat 

degenerate quadrilateral 

shell elements as C0 triangular shells. 
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● IRNXX = -1, shell normal update option. When set to -1 . Fiber direc-

tions are recomputed at 

each cycle. 

● ISTUPD = 4, shell thickness update option for deformable shells. Mem-

brane strains cause 

changes in thickness in 3 and 4 node shell elements, however elastic strains 

are neglected. This 

option is very important in sheet metal forming or whenever membrane 

stretching is important. 

For crash analysis, setting 4 may improve energy conservation and stabil-

ity. 

● THEORY = 2 (default). Belytschko-Tsay formulation. 

● BWC = 1. For this setting, Belytschko-Wong-Chiang warping stiffness 

is added. 

● MITER = 1 (default). Plane stress plasticity: iterative with 3 secant iter-

ations. 

● PROJ = 1, the full projection method is used for the warping stiffness in 

the Belytschko-Tsay and 

Belytschko-Wong-Chiang shell elements. This option is required for ex-

plicit calculations. 

● NFAIL1 = 1. Flag to check for highly distorted under-integrated shell 

elements, print a 

message, and delete the element. 

● NFAIL4 = 1. Flag to check for highly distorted fully-integrated shell el-

ements, print a 

message, and delete the element. 
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● CNTO = 2. Flag to account for shell reference surface offsets in the con-

tact 

treatment. Offsets are treated using the user defined contact thickness 

which may be 

different than the shell thickness used in the element 

 

*CONTROL_OUTPUT 

 

● NPOPT = 1. nodal coordinates, element connectivities, rigid wall defini-

tions, nodal SPCs, 

and initial velocities are not printed in the d3hsp file. 

 

*CONTROL_PARALLEL 

 

Controls parallel processing usage for shared memory computers by defin-

ing the number of processors 

and invoking the optional consistency of the global vector assembly. 

● CONST = 1. Consistency flag disabled for a faster solution 

 

*CONTROL_SOLUTION 

 

Specify the analysis solution procedure if thermal , coupled thermal analy-

sis or structural only is 

performed. 
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● SOLN = 0: Structural analysis only, if the Solver Type is set to Program 

Controlled or 

Structural Analysis Only. 

● SOLN = 2: Coupled structural thermal analysis, if the Solver Type is set 

to Coupled Structural 

Thermal Analysis. 

 

 


